Amarok stürzt ab wegen falscher Xine-Version

Da ich das Berkano-Overlay nutze, ist bei mir momentan das Paket media-libs/xine-lib in der Version 1.2.9999_p247 installiert. Das verträgt sich leider nicht mit phonon (media-sound/phonon). D.h. bei der Installation von phonon wird trotz xine-USE-Flag das xine-Backend nicht installiert. Das ist die Fehlermeldung beim emergen von phonon:

— The following OPTIONAL packages could NOT be located on your system.
— Consider installing them to enable more features from this software.
+ Xine: xine-lib v1.1.90 was found on your system. This version contains major changes compared to 1.1.x and has not been tested properly for use with this backend. Consider downgrading to version 1.1.9.
+ Xine: libxine is needed to compile phonon xine backend

Leider bricht der Kompiliervorgang hier nicht ab. Es wird einfach ohne das Xine-Backend weiter gemacht. Leider braucht aber u.a. Amarok genau dieses.

Meine (zugegebenermaßen unbefriedigende) Lösung ist das Maskieren der neuen Xine-lib-Versionen in /etc/portage/package.mask/monolithic

=media-libs/xine-lib-1.2.9999_p235
=media-libs/xine-lib-1.2.9999_p240
=media-libs/xine-lib-1.2.9999_p247

Danach sollte ein emerge xine-lib erfolgen, um wieder die alte Version zu installieren. Anschließend kann man wieder phonon installieren mit emerge phonon

Jetzt sollte auch Amarok wieder laufen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.